Показать сообщение отдельно
Старый 08.02.2009, 22:09   #4
AgentSam
Постоялец
 
Аватар для AgentSam
 
Пол:Мужской
Регистрация: 05.10.2006
Сообщений: 263
Репутация: 441
По умолчанию Re: Не открываются файлы в формате *.chm

SlipVit, качать более 600 мб, ради открытия Chm-файла, - излишне, но за "инфу" спасибо!

Max_Boy, как выяснилось запуск только данной команды проблему не решает.

Проблему удалось решить следующим образом (после перебора этих команд):

1) Пуск - Выполнить или Win+R
2) В появившееся окно поочерёдно вводим следующие команды:

regsvr32 %windir%\system32\hhctrl.ocx
regsvr32 %windir%\system32\itircl.dll
regsvr32 %windir%\system32\itss.dll

При этом после ввода каждой команды должны появиться следующие сообщения:

[Для просмотра ссылок требуется регистрация. Зарегистрироваться...]

3) Далее обязательно перезагружаем компьютер.

После перезагрузки всё должно работать (проверено на WinXP SP3 RUS).

P.S. дополнительные варианты решения проблемы (кому-то помогает; тут всё зависит от вида ОС):

Альтернативное решение №1:

0. Делаем резервную копию реестра (на всякий случай)
1. Меню "Пуск" - Выполнить - вводим команду regedit
2. Жмём ctrl+f (поиск)
3. В строке поиска вводим функцию mk:@MSITStore жмём enter.
4. Удаляем только запись mk:@MSITStore через правку с использованием клавиши F2 - всё остальное не трогаем.

Альтернативное решение №2:

Правим в реестре следующее:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x \ItssRestrictions]
"MaxAllowedZone"=dword:00000001

P.S. тему можно закрывать.
__________________
Собираю спасибки

Последний раз редактировалось AgentSam; 09.02.2009 в 09:29..
AgentSam вне форума
 
Ответить с цитированием Вверх
 
Время генерации страницы 0.08659 секунды с 9 запросами