Показать сообщение отдельно
Старый 01.04.2010, 19:07   #1
Неактивный пользователь
 
Регистрация: 01.04.2010
Сообщений: 2
Репутация: 0
По умолчанию mount_smbfs и символ № в русских именах файлов

Приветствую.

Не могу никак победить этот странный глюк.
Информация по этому глюку изредка встречается на просторах инета, но решения нигде нет.

Есть:
FreeBSD 7.2
Шара на Windows Server 2003 R2
Файловая система на шаре - NTFS

Использовал следующие конфиги:

/etc/nsmb.conf
----------------------------------
[default]
workgroup=MY_GROUP

[SRV1]
charsets=utf-8:cp866
addr=192.168.78.1

[SRV1:ADM]
password=$$16e9b5054613c1d11f7fcb39ac2b0b6bf01fe
----------------------------------

/usr/local/etc/smb-client.conf
----------------------------------
[global]

workgroup = MY_GROUP

# Charset settings
display charset = UTF-8
unix charset = UTF-8
dos charset = CP866
----------------------------------

Локаль:
/usr/local/etc/>locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_ALL=

Монтирую командой:
mount_smbfs -E utf-8:cp866 -W MY_GROUP //adm@srv1/shara /mnt/mount_shara

В корне шары есть файл с именем "Документ №1.txt"
На маунте я его вижу под именем "???㬥?? ?1.txt".
Файл нельзя ни открыть, ни скопировать - MC подвисает намертво.
Стоит лишь заменить в имени файла знак № на букву N - имя файла сразу же становится нормальным - "Документ N1.txt"

Все остальные файлы с русскими именами видны нормально, кроме тех, где встречается символ №

Как побороть?
Переименовать - не предлагать, такой вариант не подходит к сожалению.
IT_Prof вне форума
 
Ответить с цитированием Вверх
 
Время генерации страницы 0.08494 секунды с 9 запросами